General

What are the system requirements for FluidDraw?

FluidDraw runs under all versions of Windows from Windows XP, including Windows 10 (both 32-bit and 64-bit). We recommend a dual processor and at least 2 GB of RAM.

To top

Can FluidDraw automatically search for updates?

Within the program options of FluidDraw you can select to search for updates and if you whish to automatically download them on each start of the program.

To top

Installation

Can FluidDraw be installed on a network drive?

Due to additional security concepts for modern Windows applications, running programs directly from a network sharing or network storage is not possible. In order to prevent that malicious programs are distributed over the network, extended security settings are required for trustworthy programs. The FluidDraw setup can optionally make these settings. In this case it is necessary to run the “Client Installation” on each PC from which FluidDraw should be started as non-local installation. Proceed thereby as follows:

  1. Run the “Server Installation” and install FluidDraw in a location, where the Client PCs have read permissions.
  2. Run the “Client Installation” on each workstation and leave the option to set the required execution rights selected.

Note: With the “Client Installation” no files are copied on the local hard disk, but only a link to the network drive is created. This means in particular that later program updates only have to be installed on the server, while no special action on the individual workstations is necessary.

To top

How can I update my FluidDraw P5 Professional installation on my CodeMeter USB stick?

The root directory of the USB stick contains the file “start.exe”. Run this file and choose the last option “Check for updates”. Unless the stick already contains the most recent version, an update will be downloaded and installed on the stick.

In the case, the stick has been formatted or the file “start.exe” does not exist or is corrupt, you can just copy the setup/update to the stick and run it from there.

To top

Tips & Tricks

Can I create my own symbols with FluidDraw?

Existing symbols from the standard library cannot be changed, but you can of course create your own symbols in FluidDraw. To do this, proceed as follows:

  1. Draw symbol

    In principle, you can easily create a new symbol using the line, polyline, rectangle, circle, ellipse, etc. drawing functions. Use these drawing elements to draw your desired symbol in an empty schematic. In order to achieve this precisely, you can activate additional snap functions such as snap to end point, snap to center point or snap to intersection using the program menu bar. The Show grid option in the View menu displays a grid in the background. This has a grid width of 3 millimeters by default. Grid width and style can be adjusted in program options in the General tab.

  2. Create macro object

    After you have drawn the symbol, select all elements of the symbol and select Create macro object from the context menu in the schematic or from the main menu within Edit. The individual drawing elements are then combined to form a single new symbol with its own properties.

  3. Define connectors

    Via the Define connector item in the Insert menu, you can now add pneumatic, hydraulic or electrical connectors to the symbol. For the line routing of conduction lines it is optimal if these connectors are placed in such a way that they are located at at intersections with the grid.

  4. Save symbol in own symbol library

    Via the main menu item Create new library in the menu Library you can create your own symbol library for your user symbols. If you call this menu item and specify a file name, a new empty symbol library is created. You can then drag and drop the newly created symbol into the new library. When storing the symbol in the library, you can assign your own symbol name and a description for the symbol.

Now you can use the new symbol from your user library just like a symbol from the standard library in your projects.

As an alternative to creating your own macro object in steps 1 and 2, you can also import a completely drawn symbol in DXF format. To do this, use the main menu item DXF Import… in the File menu.

To top

How can the language of the attributes under catalog properties or custom properties be switched?

The Version FluidDraw S5 - Starter does not support this language change.

In Version FluidDraw P5 - Professional it depends on:

  1. What is the page’s catalog language? If there is set a language you can also change the language there.

  2. What is the project’s catalog language? If the option “Inherit from parent node” is enabled, and the page is part of a project, the language can only be defined in the parent project properties.

  3. What is the global program catalog language? If the page does not belong to a project or the option “Inherit from parent nodes” is disabled, the language of the product catalog is applied, which is set under Tools => Options => Language.

To top

The parts list is not sorted correctly. In the list X1 is followed by X11 and not X2.

In the parts list’s settings there is the checkbox “Sort As Number”. Check this box to sort the list in the desired order X1 X2 X11.

To top